See more...

Should I Upgrade iPhone 4 iOS 4.2.1 to 4.3.5 & Unlock Using Ultrasn0w 1.2.3?

Hello, I just got my first and brand new iPhone 4. It is currently locked to AT&T and running on iOS 4.2.1. I am thinking to unlock it with using Ultrasn0w since my iPhone is running on baseband 1.59.00. Now, my question is, should I upgrade it to iOS 4.3.5 and then jailbreak and unlock it? Or I will be able to unlock it on iOS 4.2.1?

Asked by: Denver from Rochester, Minnesota

Hello Denver, I would recommend you not to restore your device and STAY AWAY from iOS 4.3.5 as much as possible or you will lose the ability to unlock your device. Though you can restore a pre-jailbroken custom iOS 4.3.5 ISPW file into your device using PwnageTool 4.3.3 (with PwnageTool Bundle) to preserve the unlockable baseband of your device from getting upgraded, you will still not be able to unlock simply because Ultrasn0w does not support the newly released iPhone firmware. Additionally, if you are not aware, Apple released the iOS 4.3.4 and iOS 4.3.5 firmware to permanently patch the untethered jailbreak exploit used in the latest versions of Sn0wbreeze, Redsn0w, and PwnageTool to jailbreak iOS 4.3.1 upto iOS 4.3.3. In addition, iOS 4.3.4 and iOS 4.3.5 is also intended to patch the security exploit used in JailbreakMe 3.0. So, if you upgrade to iOS 4.3.5, aside from losing the ability to unlock you will also end up with unstable jailbreak as Redsn0w for iOS 4.3.4 and iOS 4.3.5 offers tethered jailbreak only.

In your case, I would recommend you to backup your SHSH Blobs using iFaith and then jailbreak it on iOS 4.2.1. You can use Sn0wbreeze 2.2 if you are on Windows or PwnageTool 4.1 if you are using a Mac. Once fully jailbroken, you can follow this tutorial in order to unlock your iPhone using Ultrasn0w.

Unlock iPhone 4 using Ultrasn0w

Leave a message...