See more...

No MMS on iPhone 4 After iOS 5 Jailbreak Using Redsn0w

Hi, I restored my iPhone 4 to iOS 5 couple of weeks ago, and then decided to jailbreak it yesterday using Redsn0w 0.9.9b7. After the jailbreak, I am unable to send MMS to my girlfriend. Since this is my very first iPhone, so I everything related to jailbreaking is pretty new to me. Should I restore? Please help. Thanks.

Asked by: Wesley from Deming, New Mexico

Hello Wesley, as much as possible, I would recommend you to STAY AWAY from iOS 5.0.1 or iOS 5.1 so that you will be able to get an untethered jailbreak whenever it becomes available to the general public. Anyway, have you installed any jailbreak app or tweaks prior noticing this error? If yes, then try to uninstall them and then check your device. You can uninstall it by launching Cydia and navigating to Manage tab.

Also, you can download and install Crash Reporter from Cydia Store (under BigBoss repo) to efficiently determine which apps (both Cydia and App Store apps) or tweaks are giving you the problem. Or, try to reset your network settings.

Lastly, if the above tips don’t work, then you can try the tutorial posted below on how to install iPhoneDelivery on your jailbroken iPhone 4 to fix MMS and FaceTime related issues.

Step 1: Launch Cydia app from the Springboard of your jailbroken iOS device.

Step 2: Then tapon the Manage tab followed by tapping on Sources section.

Step 3: Now you have to tapon Edit button on the top-right and then followed by a tap on Add button on the top-left.

Step 4: Then enter the following URL as Cydia/APT URL

Then tap on Add Source button.

Step 5: Now, wait while Cydia updates its sources database. Once done, tap on Return to Cydia button and then tap on Search tab at the bottom. Type iPhoneDelivery on the search tab and search for it. Then select iPhoneDelivery from the search results.

Step 6: Tap on the Install button on the top-right to install Icy on your iDevice.

Step 7: Once installed, tap on Restart Springboard button to exit Cydia.

Fix iPhone MMS Error

1 comment
Leave a message...

    Dee3 years, 7 months ago

    my message does not work at all now