See more...

iPhone 4, No Sound After iOS 5 Jailbreak Using Redsn0w 0.9.9b7

Hi, After jailbreaking my iPhone 4 on iOS 5 using Redsn0w 0.9.9b7, I have now got no audio on my iPhone. No ringing or message alert tone. Even when I play MP3 songs from iPod app, I hear no sound. But the sound is working if I connect my headphones or external speakers. But once I disconnect these accessories, the sound is gone. Please help. What’s the problem with my device? Thank you in advance.

Asked by: Robin from Holdenville, Oklahoma

Hello Robin, I am not sure if this is software or hardware related issue. But prior this error, have you install any app or tweak from Cydia Store that has something to do with your sounds? If yes, then try to uninstall it and then boot your device into tethered mode. Did you boot your iPhone into tethered mode after jailbreaking it? If not, then please do so. This step is very crucial in order to fully activate the jailbreak on your device. So to tethered boot, all you have to do is put your iPhone into DFU mode, connect it to your Mac or PC, select Extras and then click on the Just boot option.

If you still got the same error after performing the above tips, then I would recommend you to restore your phone to stock iOS 5.0.1 firmware. However, you should be noted that this new iPhone firmware will prevent you from getting an untethered jailbreak once it became available to the general public as it patches the untethered exploit that is being developed by pod2G and the iPhone Dev-Team. Anyway, after restoring your iPhone to stock iOS 5.0.1, you can follow our step-by-step guide posted here on how to jailbreak iOS 5.0.1 on iPhone 4 using Redsn0w 0.9.9b8. That’s it! Good luck!

Fix iPhone 4 Sounds

Leave a message...