See more...

JailbreakMe 3.0 Not Working on iPhone 4 with iOS 4.3.3

I got a new iPhone 4 after sending my old iPhone to AT&T for battery issues. I was expecting that AT&T will restore iOS 4.3.5 on this phone, but to my surprise the device is running on iOS 4.3.3. However, it seems like JailbreakMe 3.0 is not working on this phone. I already used (JailbreakMe 2.0) on my old iPhone as well as with my aunt’s iPod Touch, but I can’t manage to jailbreak my new iPhone. Can anyone help me? PLEASE! Thanks.

Asked by: Rodney from Olathe, Kansas

Hello Rodney, JailbreakMe 3.0 should be able to jailbreak your iPhone 4 if it is running on iOS 4.3.3. Please make sure that your device is on iOS 4.3.3 and not on iOS 4.3.4 or iOS 4.3.5 because these new firmwares are not supported by the web-based jailbreak tool. Anyway, there are also possibilities that you cannot jailbreak your iPhone due to traffic. Just visit the official website of JailbreakMe multiple times until you get a jailbreak. Also, make sure you have a better Internet / Wi-Fi connection. To make sure you have a better connection, I highly recommend rebooting your modem and router.

If the above tips do not work on your iPhone then your last resort is to jailbreak your iPhone 4 using other desktop-based jailbreak tools, such as the Redsn0w, PwnageTool, or Sn0wbreeze. In your case, since there is no way you can unlock your iPhone using Ultrasn0w, I would recommend you to jailbreak your iPhone using the latest version of Redsn0w. You can get the Redsn0w 0.9.6RC19 for Mac OS X and Windows. Once you have the latest version of Redsn0w, you can now jailbreak your iPhone using this tutorial on how to use Redsn0w. I am 99.99% sure that you will be able to jailbreak your iPhone using Redsn0w, if not then you can contact us via the comment section below.

JailbreakMe 3.0 iPhone 4 Untethered Jailbreak

Leave a message...