Results

See more...

Fix Installous 5 Installation Failed: Invalid IPA Error on iOS 5.x.x

One of the most popular jailbreak apps that most people install is definitely Installous. But as it occasionally happens, there are bound to be errors to be found when using Installous. Perhaps one of the most common errors that users encounter when working with this app is the dreaded Installous Invalid IPA Error. But the solution for the Installous installation failed error is actually quite simple. All you need is to uninstall previous installations of AppSync and then reinstall it again via the Hackulous source. In order to do that, check out our guide on how to Fix Installous 5 Installation Failed: Invalid IPA Error on iOS 5.x.x.

Installous Invalid IPA Error

Steps on How to Fix Installous Invalid IPA Error on iOS 5.x.x:

NOTE: This guide assumes that you have already installed Installous 5 on your iDevice running iOS 5.x.x. If you haven't yet installed Installous, make sure that you check out this guide.

  1. Launch Cydia from your jailbroken iPhone, iPad or iPod touch. On Cydia, tap the Search tab which is found on the bottom of the screen. Type AppSync in the search field and hit the Search button. If you have installed any previous versions of AppSync, you should see a ? sign beside it.
  2. Search-AppSync-in-Cydia

  3. Tap on the version which has a ? sign, and select the Remove option. This will remove the existing version of AppSync from your device.
  4. Remove-AppSync-from-Cydia

  5. After AppSync has been removed, tap Manage at the bottom of the screen, then tap Sources. You will see that there is a list of stock and installed Cydia repos here, look for the Hackulo.us repo and tap it. You should many different versions of AppSync, look for AppSync for iOS 5.0+ and tap it.
  6. AppSync for iOS 5.0+

  7. Install AppSync for iOS 5.0+ by tapping the Install button located at the top right of the screen.
  8. AppSync-for-iOS-5.0-Plus

  9. After successfully installing AppSync for iOS 5.0+, make sure that you reboot your iPhone for good measure. Now try installing an IPA file from Installous and hopefully the Invalid IPA Error is now resolved.

If you have any questions on how to solve the Installous Invalid IPA Error, feel free to comment on this post.

Contact Us for News Tips, Corrections and Feedback
67 comments
Leave a message...

  •  
    Dick Tracy3 years, 7 months ago

    Read the friggin comments below before asking the same question 50 times ffs… Lazy bastards, too lazy to read.

  •  
    Jitodos33 years, 8 months ago

    Theres an alternative called zeusmos but you need app sync 5.0+ and without it, it wont work. It’s been making me frusterated. Can someone help?

  •  
    Scotpig3 years, 8 months ago

    It’s gone people…Installous is dead with no immediate plans on coming back.

  •  
    Aarti3 years, 8 months ago

    Hi my installous was working before but recently its saying outdated version ..installous will now terminate,..what should i do to resolve this ?

  •  
    M.ahmed3 years, 8 months ago

    After upgrading Hackulo.us nothing is coming its totally empty and when I was doing upgrading it’s giving error in package .please help me in solving this problem how to upgrade completely .

  •  
    Scotpig3 years, 8 months ago

    Apparently hackulo.us has called it quits. Not sure if there’s an alternative or if this is a permanent thing, but if there’s no repo hosting installous, does that mean no more downloading apps altogether or what? This sucks, It was working as of yesterday Dec 29th but now it says it’s outdated and will now close?

  •  
    Genacer3 years, 8 months ago

    i don’t know why… but my iphone 4 has “installous 5” but it doesn’t work, “outdated version” “installous will now terminate”… please help me… what can i do ???

  •  
    pallavi manocha3 years, 9 months ago

    Please help i am facing the same problem-

  •  
    Emmanuel Carreon3 years, 9 months ago

    when i try to install the “appsync for iOS 5.0+” apears this mesage: the requested notifications cannot be applied due to required dependencies or conflicts that cannot be automatically found or fixied.Also appears: Depends iOS Firmware >=5.0

    •  
      karen3 years, 8 months ago

      got the same problem can u tell me what youve done thanks 

  •  
    Azhar3 years, 9 months ago

    Hi . I have iPhone 3GS on iOS 4.2.1. But I have installous 5 . I get installation failed – invalid ipa. What should I do

  •  
    -HELP-3 years, 9 months ago

    My whole installous disappear and I cant find it .

    •  
      Greyhou3 years, 9 months ago

      me too.

    •  
      Greyhou3 years, 9 months ago

      that sucks. I looked in cydia and my install0us was gone. I reinstalled it and my downloads were still there, but when I clicked “install,” I still receive the “invalid IPA” error–even though I deleted iTweaks AppSync, and then installed Hackulo.us’s and then reinstalled installous

  •  
    mohammad zuhair3 years, 10 months ago

    i have an ipod 4g with ios 6.0.1 is there a fix for it?

  •  
    SomeGuy3 years, 10 months ago

    I have an iPod 2g, with 4.2.1 and I wanna know if I should install the 4.0+ because my version is 4.2.1?

  •  
    Jas3 years, 10 months ago

    I have a iPod iOS 5.1.1 I have jailbreak it . And when I try and reinstall already it still have this error . Any other suggestions ?

  •  
    Kimwer3 years, 10 months ago

    iOS Firmware >=5.0 Doesn’t let me install AppSync, just gives me this. Halp?

  •  
    ariko3 years, 10 months ago

    reinstall appsync 5.0+ its works !!!

  •  
    Carlo3 years, 10 months ago

    I’m running an ipod touch 2g with an installed appsync 4.0+. Question: Can I still use installous 5 or do I need to get installous 4? Also, I noticed there’s this #1 icon on the changes menu in cydia and there’s an available update for mobilesubstrate. I’ve been trying to update it but to no avail. I wonder if that has anything to do with installous api error?

  •  
    bob3 years, 11 months ago

    i have ios 5.1.1 and apple sync 5.0 i still get the installation error couldi please get some help?

  •  
    Dimitar3 years, 11 months ago

    I have iphone 4 iOS 6 , i have jailbreak and instal cydia and instalation but i have the same problem , i look and it only have 5.0+ and that don’t work for me . please help ?

    •  
      Asif3 years, 11 months ago

      I also face that problem …., if you  get any solution plz tell me my mail id  patel.asif60@gmail.com

  •  
    Gustov3 years, 11 months ago

    I have an iPad 2. When I search for a specific app in installous and hit the DOWNLOAD button, I get the pop up window with the sources but when trying to hit one of them I get a blank screen where Im supposed to enter the code. I need some help with this. The only apps I have access to are the ones that are magnetized but in most cases those don’t work.

  •  
    april3 years, 11 months ago

    help..i just did upgrade to ios 6 jailbreak 3gs. my problem is when i try to install all application, it always go back to home screen..any suggestion bout this? need ur reply asap..many thanks :)

  •  
    Tushar3 years, 11 months ago

    Thanx a lot. It works

  •  
    Henky3 years, 11 months ago

    Please help the people and I who are in need of assistance for the ios6 jailbreak. Like the appsync and the white screen of installous, this gets very annoying!!!

  •  
    HolySmoke3 years, 11 months ago

    I that didn’t work for me.  to uninstall and reinstall installous. Mines working fine now.

  •  
    HolySmoke3 years, 11 months ago

    I Had to uninstall and reinstall installous. Mines working fine now.

  •  
    Xyz3 years, 11 months ago

    Hey what do you all think…?when is appsync and installous be going to relaese for ios 6..!!!! Curiously waiting for it..!!!!!!!! :p

    •  
      Rich TaTa3 years, 11 months ago

      Half a year or less…….

  •  
    Bleye3 years, 11 months ago

    i have done all of the steps, yet all i can get is the invalid ipa. if you could help, that would be great. i am using ipod 4g with ios 5.

  •  
    Elvis3 years, 11 months ago

    When do u guys think… the iOS 6 update coming out for installous…. my god

  •  
    Liam R.3 years, 12 months ago

    Done this trillions of times on my ipad and it won’t work i have ios 5.1.1

  •  
    sudheer3 years, 12 months ago

    thank you , its worked for me..

  •  
    Orpheus.C3 years, 12 months ago

    I’ve had enough with this iOS 6. I should probably downgrade the iOS of my iPhone.

  •  
    Rich TaTa4 years ago

    Ive got the same problem on my ipod touch with ios 6. I dont know, maybe its because installous isnt fully supporting ios 6, or maybe is appsync for ios 5+ not the right program for ios 6. How do I solve this?

    •  
      Patrick Gumban4 years ago

      Yes, it is most likely that Installous is not yet fully optimized for iOS 6. I did some digging around and the Invalid IPA error seems to be prevalent among users that are using Installous on iOS 6. Best thing to do is to wait for an Installous update for now.

      •  
        Jake3 years, 11 months ago

        Ugh… when do u think the update is coming…..

        •  
          Patrick Gumban3 years, 11 months ago

          Can’t really say, hopefully soon. But considering that there has been no movement on the jailbreak front, it should likely take a while. :(

    •  
      An Orks3 years, 11 months ago

      wat did u use to jailbrak it. got ios 6 on my ipone 4 but can seem to find an untethered jailbreak

  •  
    misskrisz4 years ago

    it doesn’t work for me.. its still the same problem, i tried downloading lower versions of the app i desire but nothing has changed.. it says invalid ipa again.. i need your advice.. thanks..

  •  
    Ahmed.EG4 years ago

    thats so weird , the error message is gone but still cant install the App i want , usually it says installed after its done , now no errors but no installaton too lol 

  •  
    Otie4 years ago

    Well it worked for me. I installed two apps before the same error came up but I tried again and it worked. I didn’t have app sync installed before I read this though.

  •  
    Tahaboy4 years ago

    There is still an error on ipa on my iPod touch 4th gen. Please help :(

  •  
    Y.n4 years ago

    The problem doesn’t get resolved ><I have iOS 5.1.1 and I installed installous 5 and AppSync for iOS5.0+But it just keeps giving me the same invalid IPA error no matter how many times I remove and install. Please help!

  •  
    eevra4 years ago

    installous 5 gets installed in my iphone os 4.2.1 iphone 3g , but the iap errors come. do I need to remove installous 5 & install only 4 only along with appsys ver 4.0 ?

    •  
      Patrick Gumban4 years ago

      Yes, if Installous 5 doesn’t work on your device due to incompatible iOS version, you should stick with previous versions. Yes, you might want to install Installous 4 with Appsync 4.0+.

    •  
      eevra4 years ago

      i do not get installous from hackulou repo, only ver 5 , i could see. But there a number of installous 4 versions & they are not installing leaving ‘cannot comply ‘ errors. dependencies with appsync 3 etc., etc.,

  •  
    Julio Gonzalez4 years ago

    when i delete de appsync 4.0 it deleted to my instalous 5 help plzz 

  •  
    khurram4 years ago

    well i m using ios version 4.2.1 on iphone 3g. i have installed installous 5 on that but appsync 5.0 or 5+ not gonna work on that as my ios will not support it, so how can i fix this prblm now??? :)

    •  
      Patrick Gumban4 years ago

      I’m sorry, you will have to stick with the Installous version that your iPhone supports. Installous 5 and Appsync 5.0 is for iOS 5 only. If you are having problems with IPA errors, you can try removing and installing Installous, Appsync and even the Hackulous repo altogether.

      •  
        SeptonSeveren3 years, 11 months ago

        You can install Installous 5 on an iPhone 3G – you will simply need to install the AppSync 4.0+ version rather than the 5.0+ version, found on the Hackulous repo.

  •  
    Dakota Fraser4 years ago

    Do I reinstall installous at the end?

    •  
      Patrick Gumban4 years ago

      Hi, It is not necessary to reinstall Installous, just remove old versions of AppSync and install the latest one.

  •  
    Mon Rush4 years ago

    works fine! 

  •  
    AungKaungHein4 years ago

    Yes!! It works for me. Thanks. xD

  •  
    Sanchit4 years, 1 month ago

    Not working for afl gold edition

  •  
    SunnyBoy4 years, 1 month ago

    @a873fdb646735306662afcae37522be1:disqus yes you can install the latest version. i am using an iphone 4 and i installed the latest version and it works fine

    @00e49bbfa7ddb5c5826d0e901c02fdaa:disqus even i didnt see any remove option. try installing the latest version, it should work fine. if it doesnt, go to cydia and locate the old version and uninstall it. then download the new one.
    step 3 – maybe you havent added the resources that offer the latest version. try watching a video on youtube that mentions top 10 resources for cydia. it should help a lot and will definitely give you a lot of options.

  •  
    peter4 years, 1 month ago

    step no 2, i cannot find remove option. only install option.
    step no 3, the latest only AppSync for OS 3.2

  •  
    virk4 years, 1 month ago

    still not solved problem

  •  
    gatsssuu4 years, 1 month ago

    can i install appsync 5.x rather than 5.0?