Results

See more...

Ultrasn0w Fixer Released to Unlock iPhone 4, 3GS on iOS 5.1

The iPhone Dev team has released Ultrasn0w Fixer, a new update that will allow unlockers to use iOS 5.1. If you were one of the unlucky users who had an unlocked iPhone but upgraded your iPhone to the new iOS 5.1, you are in luck.

There is a new fix that will allow users to keep their unlock while running on iOS 5.1. Ultrasn0w fixer only works for the following basebands:

  • 01.59.00
  • 04.26.08
  • 05.11.07
  • 05.13.01
  • 05.12.01
  • 06.15.00

If your baseband is not one of these mentioned above, then tough luck, Ultrasn0w Fixer will not help you. If your baseband is included on the list above then read on.

Steps to Unlock iPhone 4 and iPhone 3GS Using Ultrasn0w Fixer

The unlock using Ultrasn0w is pretty much straightforward if you have already unlocked your iPhone 3GS/4 before and know the basics. You will need to download Ultrasn0w Fixer from the following repo in Cydia (add this source):

http://repo.iparelhos.com

If you want a more in depth guide on how to install ultrasn0w Fixer, read on for a step by step guide.

Pre-Requisites Before Starting:

Your iPhone needs to be jailbroken. This can be done through Redsn0w if it isn't already done. If you need to know how to jailbreak your iPhone using Redsn0w, please visit our tutorial on how to jailbreak your iPhone on iOS 5.1 using Redsn0w.

You also need to have your baseband preserved. This means that if you have upgraded without creating a custom ISPW, you are out of luck. In order for Ultrasn0w Fixer to work, you need to have one of the basebands mentioned above. If this is confusing to you and you need to know how to check your baseband, please visit our page about iPhone basebands.

1. Open Cydia and go to Sources

2. Add the source: http://repo.iparelhos.com

ultrasn0w Fixer repo

3. After adding the source go to search and search for "Ultrasn0w Fixer"

ulrasn0w fixer search

4. Install Ultrasn0w Fixer

install ultrasn0w fixer

5. After you install Ultrasn0w Fixer, go back into the search and install "Ultrasn0w"

ultrasn0w after ultrasn0w Fixer

6. That's it! Ultrasn0w Fixer is installed and Ultrasn0w should be working normally on your iPhone running iOS 5.1

Contact Us for News Tips, Corrections and Feedback

Related posts

10 comments
Leave a message...

  •  
    Darren3 years, 9 months ago

    I’m wondering if this works for iphone 3gs with baseband 05.13.04?

  •  
    jordan curran3 years, 11 months ago

    still not working. tried it on my 3gs with ios 6 and 6.15.00 firmware but everytime it either says searching or no service. and everytime it tells me i can upgrade the fixer and it doesnt let me. any help would greatly be appreciated. thanks!

  •  
    Daniel Todero4 years ago

    tks a Lot! i you’re the man!!!!!!!! tkyou!!!!!!

  •  
    Ans4 years, 2 months ago

    Thanks guys this is helpful

  •  
    ELVRHOADS4 years, 3 months ago

    @Jaxov i hav unjailbroken iphone4w/ iOS4.3.5(8L1) w/gevey simcard. Iwant to update it to any iOS 5 that is tethered. can u pls tell me how?

  •  
    Matthewhaotran4 years, 5 months ago

    I am on iOS 5.01.  So do I do all of this while on it and then upgrade through settings –> software update to 5.1?

    •  
      Pesmerga4 years, 5 months ago

      Never update through iTunes or OTA if you are relying on an unlock. Always create a custom IPSW when upgrading in order to preserve your baseband and unlock.

  •  
    Satyam4 years, 6 months ago

    What about us,with not saved basebands? Is there a chance for us soon? Sinse I upgrade it to 06.15.00 Apple remembers me all the time about shot I’ve done :-)

  •  
    Ozamora764 years, 6 months ago

    No unlock for Iphone 4S yet?