See more...

How to Fix PwnageTool Wrong Firmware Bundle Selected Error?

Just like other jailbreak tools like Redsn0w and Sn0wbreeze, if you'll provide PwnageTool with a faulty firmware file, it will error out wrong firmware bundle selected message. For those who don't know, PwnageTool is a jailbreak tool by iPhone Dev-Team which helps all iPhone, iPod Touch and iPad users to jailbreak their iDevices by creating and restoring custom cooked IPSWs of supported firmware.

PwnageTool Wrong Firmware Bundle Error
PwnageTool can throw wrong firmware bundle selected error mainly because of the following 3 reasons explained below:

Wrong PwnageTool or IPSW Version:

Only certain PwnageTool versions can jailbreak certain firmwares on certain iDevices. So first make sure to check the compatibility of both PwnageTool and firmware file. To find out, just visit PwnageTool archive here.

Corrupt Firmware File:

To check if your firmware is corrupt or not, download Marxio File Checksum Verifier from here and check MD5 and SHA1 checksums of the stock IPSW.
Marxio FCV
To find correct checksum values from which you can compare the checksums of the stock IPSW, use TheiPhoneWiki website.

Wrong Firmware Extension:

Someone people download the stock IPSWs from torrents or other unofficial mirrors. These firmware files usually have .ZIP extension. Providing an IPSW file with .ZIP extension to PwnageTool results in wrong firmware bundle error. So make sure the name of firmware file ends with .IPSW extension.

Contact Us for News Tips, Corrections and Feedback

Related posts

Leave a message...

    DbelloC5 years, 6 months ago

    I tried your guide on using the pwnage tool version 4.3 to jailbreak my iphone 4 downloading all the suggested versions of iTunes, Pwnage Tool and the correct version of ipsw (iPhone3,1_4.3.2_8H7_Restore.ipsw) and it shows the wrong firmware message.
    I came to this guide but I am a Mac user so I can’t use the Marxio application. Is there a solution for mac users to check if the firmware is corrupt? I downloaded from the sources you linked so I guess that is the same one you successfully used.
    Any thoughts?

      Wolverine5 years, 6 months ago

      To jailbreak iOS 4.3.2, you need PwnageTool 4.3.2 which you can download from here PwnageTool 4.3 is for jailbreaking iOS 4.3.1 only.