Results

See more...

Download Ultrasn0w 1.2.2 to Unlock iPhone 4/3GS on iOS 4.3.2 [How-To Guide]

iPhone Dev-Team has just released official Ultrasn0w 1.2.2 update to unlock iPhone 4/3GS on iOS 4.3.2. You can use Sn0wbreeze 2.6 on Windows and PwnageTool 4.3.2 on Mac OS X to jailbreak your iPhone on iOS 4.3.2 while preserving its old baseband. Once jailbreaked, follow the step-by-step guide below to unlock your iPhone and fix 1-signal-bar issue on iOS 4.3.2.

iOS 4.3.2 Jailbroken & Unlocked

Supported Basebands:

  • 04.26.08
  • 05.11.07
  • 05.12.01
  • 05.13.04
  • 01.59.00
  • 06.15.00
  • 05.14.02 via 06.15.00 » [How-To]
  • 05.15.04 via 06.15.00 » [How-To]
  • 05.16.01 via 06.15.00 » [How-To]
  • 05.16.02 via 06.15.00 » [How-To]

Unsupported Basebands:

  • 05.14.02
  • 05.15.04
  • 05.16.01
  • 05.16.02
  • 02.10.04
  • 03.10.01
  • 04.10.01

Steps to Unlock iPhone 4/3GS on iOS 4.3.2 with Ultrasn0w 1.2.2:

  1. Launch Cydia on your jailbroken iPhone.
  2. Cydia on iOS 4.3.2 (Main)

  3. Tap on the Manage tab followed by a tap on Sources section. Here you will see list of stock and custom Cydia sources. If you see repo666.ultrasn0w.com already added in sources list, jump to step 6.
  4. Cydia on iOS 4.3.2 (Manage)

  5. Tap on the Edit button on the top-right followed by a tap on Add button on the top-left. Enter http://repo666.ultrasn0w.com as Cydia/APT URL and hit the Add Source button.
  6. Ultrasn0w 1.2.2 Repo

  7. Now wait while Cydia updates its sources list. Once done, tap on the Search tab at the bottom and type Ultrasn0w in the search field.
  8. Search Ultrasn0w 1.2.2

  9. Select Ultrasn0w from the search results and hit the Install button on the top-right.
  10. Ultrasn0w 1.2.2

  11. Wait while Cydia installs Ultrasn0w 1.2.2 on your iDevice. After installation, tap on the Restart Springboard button to respring your iPhone.
  12. Ultrasn0w 1.2.2 (Installed)

  13. If for some reason Ultrasn0w 1.2.2 fails to unlock your baseband, try Ultrasn0w fixer by DjayB6. For me, both of them worked flawlessly. If you have any question regarding unlocking your iPhone, feel free to ask in the comments section below.

Contact Us for News Tips, Corrections and Feedback

Related posts

144 comments
Leave a message...

  •  
    Cinda2 years, 4 months ago

    Heya i am for the first time here. I found this board and I to find It really useful & it
    helped me out much. I hope to present something back and aid others
    like you aided me.

  •  
    Darleen3 years, 5 months ago

    What a great post, thanks for sharing this.

  •  
    Neel4 years, 9 months ago

    Hi buddy
    I have iPhone 4 ISO 5.0.1 with 4.11.08 baseband
    Can you help me for unlock my iPhone
    I want to use it in india

    •  
      Patrick4 years, 9 months ago

      Hi,

      Unfortunately, as of the moment there is no unlock solution for 4.11.08 baseband which comes with iOS 5, so you can’t use either Gevey or Ultrasn0w. All you can do for now is wait for an unlock solution from the jailbreak community. :(

  •  
    Anil4 years, 10 months ago

    hi pramod! i want to buy an iphone4 from my friend in US. i want to know what IOS version and BB of iphone4 should i tel him to buy so that i can unlock it in india….

    •  
      Pramod4 years, 10 months ago

      Its not like Apple is going to give you a choice of your iOS to choose from. If that was the case, things would be alot more different. You will get your brand new iPhone with iOS 5.0.1 no matter from where you buy it from US. Buy the factory unlocked version instead because iOS 5.0.1 can’t be unlocked by any available means at the moment.

  •  
    Sammy5 years ago

    Hi Pramond,

    me again : the guy with 05.16.00, Iphone 3gs new bootrom, ultrasnow 1.2.3 … i have a idea, but i need your help…I found a link to download ultrasnow 1.2.2, but I couldn’t find a link to download ultrasnow fixer for 4.3.2 from the repo of djayb6 … I know that 1.2.3 resolve problems, but I would like to try that too. Could you pleeeeeeeease help me?

    thank you.

    •  
      Pramod5 years ago

      First off, Djayb6’s repo does not host the Ultrasn0w fixer anymore because back then, Ultrasn0w itself wasn’t fixed by the iPhone Dev-Team for the iOS 4.3.x. So, there is no point in using either of them as long as your on a BB version of 05.16.xx which is unsupported & your still looking forward to unlock your iP3GS. Neither will Ultrasn0w 1.2.3 unlock your iP3GS for you.

  •  
    Prabhu Kafle5 years, 2 months ago

    hi guys! i tried tried tried and i was locked to telstra. cudn’t pay the bills and was stuck with iphone 3gs with 4.3.3 and boot 359.3.2 new bootrom and finally after i did restore my iphone to it’s original 4.3.3 with restore ipsw and then directly installing redsnow and installing the ipad basement, it did work on 4.3.3 cool guys finally now i can use any sim. ! thanks heaps to the genuis teams, the Cydia mainly and also to the ultrasnow teams. you guys are genuis. cheers.

  •  
    POLO5 years, 2 months ago

    My iphone 3gs 32gig running on firmware 4.2.1 and baseband 5.16.02 was jailbroken and unlocked but….. slight problem cant make phone calls plus i only have one bar.. help. help. i am a NB i really want this phone im tired of my htc inspire please help. sos…sos…..sos.

    •  
      Pramod5 years, 2 months ago

      You need to know that 05.16.02 is an Ultrasn0w unsupported BB. So your iP3GS was never unlocked (other than if it was a factory unlocked one) in the first place. Using Ultrasn0w on your BB did no good because it simply won’t work. Instead, you need to update your BB to an iPad BB first & then use Ultrasn0w for an unlock. Read this http://bit.ly/jVI3cT.

  •  
    Venky5 years, 2 months ago

    Hi Pramod, Thanks, Gevey SIM worked for me. It is unlocked my phone to network, all other services also working fine for me.

  •  
    Venky5 years, 2 months ago

    Hi, I have installed iOS 4.3.3 on my iPhone 4 and my baseband is 4.10.01 is there any unlock solution for this ? I have tried ultrasn0w, but it didnt worked out, still my iphone showing No service or single bar…

    •  
      Pramod5 years, 2 months ago

      That is because your trying to install Ultrasn0w onto a BB which is not compatible with it in the first place. The only way to get yourself unlocked is by using a Gevey SIM interposer. Currently, none of the BB versions starting from 02.10 and above are unlockable. No s/w unlock is expected anytime soon for the iP4 BB>=02.10.xx.

  •  
    Romulo Ruiz5 years, 3 months ago

    Sorry Pramond, you are rights thanks very much.

  •  
    Romulo Ruiz5 years, 3 months ago

    Hi Pramod, and all friend in this forum

    When I set about version 04.10.0 I’m talking about iphone 4 system version 4.3.2

    and baseband 04.10.0 because this it’s my iphone 4 version, so I never see this baseband only 04.10.01, is possible to update from 04.10.0 to 04.10.01 ???

    •  
      Pramod5 years, 3 months ago

      If you have installed an iOS 4.3.x, your BB will always be 04.10.01. Goto your Settings>>General>>About & see what your Modem Firmware reads as. It’ll be 04.10.01.

  •  
    Romulo Ruiz5 years, 3 months ago

    Hello guys,

    What the difference beetwen baseband 04.10.0 and 04.10.01
    Can Ultrasn0w 1.2.2 unlock baseband 04.10.0 or the’re any way to update baseband 04.10.0 to 04.10.01?

    •  
      Pramod5 years, 3 months ago

      04.10.0 is an invalid BB version. There exists no such BB. The only BB in the 04.xx.xx series is 04.10.01 which is found in the latest iOS 4.3.3. NO, Ultrasn0w cannot unlock the 02.xx,03.xx & 04.xx BB versions.

  •  
    purehate5 years, 3 months ago

    Hi Again Pramod,

    I updated my iPhone 3g with iTune
    now I cant jailbreak my iPhone…
    IOS 4.2.1
    Baseband 5.15.04

    Y IPSWsss need jailbreak If they r not made by Apple.Inc?
    Do u knw any custom IPSW which is allready jailbreakd and just we have to install through iTune …

    •  
      Pramod5 years, 3 months ago

      You can go ahead and jailbreak your iPhone by using Redsn0wRc16 by following this guide http://bit.ly/kPhfh0. Make sure you substitute the 4.3.3 in this post with your 4.2.1 IPSW. This method will not require any Custom IPSW. You’ll still need the stock IPSW from Apple.

  •  
    M Tabish5 years, 3 months ago

    is there any proper way to unlock the Iphone4 with base band 03.10.01 except the gevey Sim ???? need help

    •  
      Pramod5 years, 3 months ago

      Nopes. Gevey is the only solution right now. :(

  •  
    purehate5 years, 3 months ago

    I unlocked my iPhone and installed apt.yellowsn0w.com but that gave error to me..
    so after that I installed repo666.ultrasnow.com and every thing is fine…
    I restarted my iPhone.

    Still my SIM ( TATA DoCoMo ) is not working…
    is any problem with my SIM

    •  
      Pramod5 years, 3 months ago

      Your iPhone details ? Your iOS and BB versions are required for me to answer. Also yellosn0w is outdated as this was for the earlier BB versions. Use ultrasn0w instead from here http://bit.ly/lAcuoN to unlock your iPhone. :)

      •  
        purehate5 years, 3 months ago

        Here R my iPhone Detaials

        version 4.2.1 (8c148)
        modem firmware 05.15.04

        •  
          Pramod5 years, 3 months ago

          Seems like your on an iPhone 3G/3GS. 05.15 is an unsupported BB, meaning, you’ll not be able to unlock the same via Ultrasn0w. You need to update your BB to an iPad BB which is 06.15 to get yourself unlocked. Since your still on 4.2.1, all you need to do is to follow this tutorial here http://bit.ly/lccwoE to update your BB to an iPad BB and unlock the same. Don’t use any earlier veersions of yellowsn0w. They were good only for the older versions. I must warn you that once you update to an iPad BB, you’ll face issues with the GPS functionality of the iPhone. This is a known issue which is not yet resolved. Good luck.

          •  
            purehate5 years, 3 months ago

            hello
            I m updating my BB from this tutorial http://bit.ly/lccwoE

            Redsn0w-: redsn0w_win_0.9.6rc16
            iPhone2,1_4.1_8B117_Restore.ipsw

            all is well but, at last ….
            redsn0w stuck at Rebooting device :(

            And give me the link of lattest Redsn0w
            thanx

          •  
            Pramod5 years, 3 months ago

            The latest version of RS is RC16. If you still want to re-download it, you can do that from here http://bit.ly/kOhAeX. Getting stuck at the Reboot screen is a common issues due to CPU affinity. The guide that your using is an outdated one. PLease follow the latest guide for RS jailbreak here http://bit.ly/kPhfh0. Make sure your run it in Windows XP SP2 compatibility mode. :)

  •  
    Miss j savage5 years, 3 months ago

    Hi, hoping someone can help. Recently bought a 3GS from a friend. It’s jailbroken and unlocked and I’m currently iOS 4.3.3 and bb 06.15.00 using it for tmobile. Anyone know if vvs is possible? I have to call voicemail to receive all new voicemails. Visual voicemail was available on my android. Any help would be awesome thanks.

    •  
      Pramod5 years, 3 months ago

      Seems like you haven’t activated Visual Viocemail just yet. On the Apple iPhone, you can set up your Visual Voicemail by following the below steps:

      1. Select the Phone app from your Springboard Dock.
      2. Select Voicemail from the tabs at the bottom of the screen.
      3. Tap the Set Up Now button in the middle of the screen.
      4. You will be asked to enter a Visual Voicemail password. Enter a password then press the Save button at the top right of the screen.
      5. Again re-enter the same password to Verify.
      6. Go ahead and set up your Custom Greeting message/ Default messages.
      7. Record your greeting and make sure that the message is Saved.
      8. You have setup your voice mail successfully. Now, you’ll get a list of voicemails on your device
      9. You can click to select a message then press the blue play button to the left to listen to the message. Use the blue right arrow to display contact information. The green Call Back button will call the contact and the red Delete button will remove the message from your VoiceMail inbox.

      Voila, you have VVS activatated on your iPhone. :)

      •  
        Miss j savage5 years, 3 months ago

        Voicemail tab is not showing a set up voicemail button option. Anything I am missing?

        •  
          Pramod5 years, 3 months ago

          What is it showing otherwise when you tap the Voicemail button?

          •  
            Miss j savage5 years, 3 months ago

            I wish I could post a screen shot for you. It looks basically like the voicemail page. It have the top banner saying “voicemail” with two buttons one on either side of the word one says greeting the other says speaker. Blank space in the middle and then two buttons one says “call back” the other says “delete”. Normal phone spring board on bottom. I tried to troubleshoot with tmobile, they were no help at all. I’m wondering if I need to download a fix? Or is it because I had to disable 3G to use my tmobile sim?

          •  
            Pramod5 years, 3 months ago

            It means, Voicemail is active and you’ll be able to receive them w/o any issues. You’ll need to keep your 3G switched OFF all the time since the iPhone h/w doesn’t support the T-Mobile’s 3G frequency. So no point in putting it back ON, it’ll just loose your available signal and will show No Service. Can you call T-mobile up to see if everything is fine from their side. Have you setup a Voicemail a/c as well with T-Mobile?
            Try to set up your voicemail account again, you can do this by following the these steps:

            1. From the device, press and hold 1 or dial 123.
            2. If you are prompted for a password the first time you access your voice mail account again, use the last four digits of your mobile number.
            3. When prompted, create your new password and record your greeting and your name. After completing these three steps, you will have full access to the voice mail account again.
            NOTE: Your new password can be any code of 4 to 7 digits.

  •  
    Michael5 years, 3 months ago

    i have and iphone 3gs 16gb on ios 4.1 with a baseband 6.15.00 and im in the uk will it work for me

  •  
    tabish5 years, 3 months ago

    Dear,

    its nice way to unlock the iphone 4.3.2 but when i am installing repo666.ultrasn0w.com it starts to update but at end it gives me some errors and its not installing, i am writing the error below

    * cached failure
    * failed to fetch
    http://cydia.zodttd.com/repo/cydia/dists/stable/main/binary
    -iphoneos-arm/packages.gz cached failure
    * some index files failed to download, they have been ignored, or old ones used instead.

    how can i fix these errors and install properly in my iphone

    hope you will find the solution for me waiging for your reply

    thanks and regards
    Tabish

    •  
      Pramod5 years, 3 months ago

      Give it a try after a few hours. Probably there’s some error at the backend. Nothing to worry about. It’ll work good after sometime. :)

  •  
    Padawan5 years, 4 months ago

    http://www.turboimagehost.com/p/7253573/Forecast.jpg.html is the problem right, and if, will I be able to do unlock in another way such as untethered? Or maybe in the furture?

    And if I’m able to somehow unlock, would you mind helping out.. Thanks mate

    •  
      Wolverine5 years, 4 months ago

      That F0recast tool is not updated, so it do not knows that iPad baseband is unlockable. You are already jailbroken untethered on iOS 4.3.3. All you need is to install Ultrasn0w 1.2.3 through Cydia.

  •  
    Padawan5 years, 4 months ago

    When I enter redo666.ultrasn0w.com It runs a cmd, but I get a fail in the final part:

    cached failure

    http/1.1 404 not found

    failed to fetch
    http://apt.saurik.com/dists/ios/550.58/main/binary-iphoneos-arm/packages.gz Cached Failure

    Failed to fetch
    http://apt.modmyi.com/dists/stable/main/binary-iphoneos-arm/packages.gz HTTP/1.1 404 Not Found

    Some index files failed to download, they have been ignored, or old ones used instead.

    I have tried to jailbreak i serveal times

  •  
    Padawan5 years, 4 months ago

    Hi there!
    I bought a 3gs from a friend and tried to install: http://bit.ly/m5KSHI got the 1015 thou, but kicked it out of recovery with “fixrecovery 4.3”. Next step was to unlock it, which I with ultrasn0w 1.23, got a few errors when running redo, but there wasn’t a problem when trying to install it after. I reboot my phone and insert my SIM-card. This is were the problem is.. I get the service providers name along with the 3g – symbol. But there isn’t any signal at all, when I switch 3g, on – off, the phone shows 1-bar temporary. But after that there isn’t any signal at all. I call dial 112, no problem, but I cannot call, send sms, mms or receive any of these..

    I called my own service provider to make sure the phone wasn’t emei locked. And it ain’t.

    I did the exact same thing with iOS 4.3.2 along with ultrasn0w 1.2 and the problem occurs..

    I have read a lot of tutorials on how to install jailbreak and unlock properly, besides from the 1015 and the error on repo. I think it’s done after the book..

    I’m not sure whether it’s a hardware problem, since he sold it too me in recovery mode..

    I’ll appreciate any help to fix this problem. Thanks!

    •  
      Wolverine5 years, 4 months ago

      You forgot to tell me the most important thing -> Your baseband version?

      •  
        Padawan5 years, 4 months ago

        06.15.00

        •  
          Padawan5 years, 4 months ago

          BTW I had a signal for like two hours, and then its gone..

          •  
            Padawan5 years, 4 months ago

            When I tried my GF sim card on the phone, and afterwards switched to my own. I got a signal and it disapered after two hours

          •  
            Wolverine5 years, 4 months ago

            I will recommend you to restore iOS 4.3.3 custom IPSW made with PwnageTool and then unlock it using Ultrasn0w 1.2.3. Ultrasn0w definitely can unlock all iPhone 3GS with iPad bb. The only issue is that Ultrasn0w 1.2.2 or 1.2.3 do not work well on iOS 4.3.3. If you got signal then it means your iPhone is unlocked. There is NO way it re-locks itself after sometime (2-hours in your case.)

  •  
    Padawan5 years, 4 months ago

    Should I use sn0wbreeze to greate a custom .ispw as done with 4.3.2? Or is it enough to use redsn0w?

    •  
      Wolverine5 years, 4 months ago

      You can only restore iOS 4.3.3 custom IPSW made with Sn0wbreeze 2.7 or PwnageTool 4.3.3. So Redsn0w is out of question here as it requires you to restore stock IPSW. Restoring stock iOS 4.3.3 IPSW on iP3GS with iPad bb will result in infinite recovery mode loop.

  •  
    Padawan5 years, 4 months ago

    Hi there Wolverine.. GJ with all the fast replies! Here’s the deal! I bought a Iphone 3gs of a guy from the internet. Checked on a few site and called a phone provider to make sure the imei wasn’t banned, it wans’t.

    I shortly after installed iOS 4.3.2 with upgrades on BB to 06.15.00. Got the error(1015) but kicked it out of recovery mode with “fixerecovery43” and the jailbreak worked, np. But When I try to unluck it, I installed Ultrasn0w 1.2.1 and fixer DEB and installed them. My phone providers name is showned. But there isn’t any signal at all. When I used sn0wbreeze I marked the hacktivate, since I don’t the orginal service provider.. Do you have the slightes idea of a problem solver?

    •  
      Wolverine5 years, 4 months ago

      Do not use any fixer now as official Ultrasn0w 1.2.3 http://bit.ly/itMs7o is out. Also upgrade to iOS 4.3.3 as iOS 4.3.2 is known to have some issues with Ultrasn0w 1.2.2. I can confirm that Ultrasn0w 1.2 or Ultrasn0w 1.2.1 or Ultrasn0w 1.2.2 do not unlocks iPhone 3GS users with iPad baseband. You can read the response of many 3GS users in the comments below. However all those who upgraded to iOS 4.3.3 and used Ultrasn0w 1.2.3 managed to unlock their iP3GS with iPad bb. So give it a try!

  •  
    Justin5 years, 5 months ago

    You guys saved me from selling my iPhone….THANK YOU!!!!

  •  
    Arrrgggghhhhh5 years, 5 months ago

    I have done a jailbreak with redsn0w and installed cydia, I followed the steps to add ultrasn0w to cydia but my phone doesn’t work, I followed the instructions for the fixer but when I search cydia for the ultrasn0w fixer it dosen’t show up. :( What do I do next?

    •  
      Wolverine5 years, 4 months ago

      Whats your current baseband version?

      •  
        Arrrgggghhhhh5 years, 4 months ago

        How do I tell what my baseband version is?

        •  
          Arrrgggghhhhh5 years, 4 months ago

          figured that out it is 04.10.01

          •  
            Wolverine5 years, 4 months ago

            Ultrasn0w 1.2.2 or any other Ultrasn0w fixer can not unlock iPhone 4 04.10.01 baseband. This is the most latest version of iPhone 4 baseband and it is yet to be unlocked by iPhone Dev-Team!

  •  
    Charger5 years, 5 months ago

    I JB my iphone 3gs a few weeks back without any issues with Ios 4.2.1 and bb 06.15 using greenpois0n and ultrasnow, but yesterday i try to install celeste from a repo and since then my iphone keep saying invalid sim card. Everything else works like a charm. Any suggestion.
    Can i install iOS 4.3.2 or 4.3.1 in this devive with BB 06.15

    •  
      Wolverine5 years, 5 months ago

      Celeste have nothing to do with unlocking. You can only restore iOS 4.3.2 (No SHSH Req) or iOS 4.3.1 (SHSH blobs required) custom IPSWs to upgrade your current firmware. Restoring stock IPSW will result in infinite recovery mode loop!

  •  
    Roman5 years, 5 months ago

    Hello,
    It seems like you reply on this website I hope you can help me!!
    I’ve had the biggest headache with my iPhone 3GS new boot
    firmware:5.16.02
    version:4.3.2
    Ultrasn0w:1.2.2
    I’m using tmobile and it’ll search for the network and come up “no service”
    I’ve tried all the basic things!! 3g off, airplane mode on/off, reset networ settings, reinstall ultrasn0w, reboot device, reinstall ultrasn0w rebot device then install, EVERYTHING!! AGHGHGh.
    I thought these djayb6 or pushfix.info ultrasnow fixes would work but they’re removed to my understanding.
    PLEASE HELP ME!!!!!
    Thanks a bunch!

    •  
      Wolverine5 years, 5 months ago

      You need to upgrade your baseband 5.16.02 to iPad baseband 6.15.00. Ultrasn0w or any other fixer can not unlock baseband 5.16.02 until you upgrade your current baseband to iPad bb.

      •  
        ana5 years, 4 months ago

        hi do you know if they are going to release something to unlock the actual 5.16.02 without upgrading it to the 6.15.00 baseband? thanks :)

        •  
          Wolverine5 years, 4 months ago

          Nops. Ultrasn0w to unlock iPhone 3GS 05.16.01 or 05.16.02 will never become reality. MuscleNerd of iPhone Dev-Team has already confirmed this. You must upgrade your current baseband to iPad baseband.

  •  
    Marco5 years, 5 months ago

    great job guys. is there any chance that the 04.10.01 baseband fix will be released this week?

    •  
      Wolverine5 years, 5 months ago

      Nops (Not for next 2 months atleast). I will recommend you to go for Gevey.

  •  
    X25 years, 5 months ago

    How much dB is considered a good signal strength?.

    •  
      X25 years, 5 months ago

      Sorry, i got my answer from above posts. Didnt look there before…

  •  
    Aatif5 years, 5 months ago

    There is a serious issue……i have jailbreak my iphone 4 firmware 4.2.1 with baseband 03.10.01 through Redsnow 0.9.6 b4 and then installed Ultrasnow 1.2.2 and after installation i clicked the Reboot and from that time its showing APPLE LOGO on the screen…….PLZZZ HELP ME PLZZZZZZZ

  •  
    Sam5 years, 5 months ago

    Hi Dear ,

    I got baseband 2.10 originally for iOS 4.1 and I am using gevey sim. And now I am on 4.3.2 with 2.1 baseband.

    I gone through your reply and find that gevey cannot be used with this signal bar fix. So, what will happen if I install this fix and use gevey sim at the same time ? Is it reversible ?

    If that is not gonna work, do you suggest me to get to the 4.3.2 while preserve baseband 2.10 and get one signal bar, and wait for the 2.10 baseband crack. Or to get to the 4.3.2 with latest baseband and get full signal bar as the team decided to work on the latest baseband instead of the old 2.10?

    •  
      Wolverine5 years, 5 months ago

      There is no need to install Ultrasn0w 1.2.2 or Ultrasn0w 1.2.1 or Ultrasn0w fixer when you are using Gevey. I am on iOS 4.3.2 with 03.10.01 baseband and i am using Gevey with full signal-bars. Just jailbreak your iPhone with Sn0wbreeze 2.6 http://bit.ly/gBOM7o or PwnageTool 4.3.2 http://bit.ly/etlFRp and do not forget to hacktivate it. Proceed to iOS 4.3.2 only if you have iOS 4.1 SHSH blobs so that you may downgrade your firmware later if you are not satisfied with its performance.

      •  
        Sam5 years, 5 months ago

        Umm.. I mean if it is better for me to keep in 2.10 or upgrade to 3.10 or whatsoever baseband come with 4.3.2 ?

        Because actually I prefer software unlock than dialing 112 then wait for a long time (although it’s only a voice recording even if connected to 112 without a valid sim).

        and by the way I have a original ATT sim , so no need hacktivate it and no need to install sam ?

        Thank you ~!

        •  
          Wolverine5 years, 5 months ago

          No, you should definitely keep your current 2.10 baseband. Also to unlock with Gevey SIM, you have to dial 112 for 2 seconds (Even if the call DO NOT connects) and it works flawlessly :D Yep you do not need to hacktivate and install SAM if you have genuine AT&T SIM card.

          •  
            Sam5 years, 5 months ago

            Thank you for your advice, and I am on 4.3.2, 2.10 bb and Gevey SIM …
            I got 1 signal bar … and what’s worse , the message for dialing 112 does not shows up quite often and also the “No Sim installed” message often not appear after turned to airplane mode …

            so that why I am asking >_<
            T_T

          •  
            Wolverine5 years, 5 months ago

            Always follow this guide http://bit.ly/f2n5VU to unlock your iPhone with Gevey!

          •  
            Sam5 years, 5 months ago

            Yes that is what i am doing

            and I still get 1 signal bar …

          •  
            Wolverine5 years, 5 months ago

            Give this guide a try http://youtu.be/E7DTCs1eNiw If it do not work then call 112 and tell me the response you get.

          •  
            sam5 years, 5 months ago

            Thank you for your reply again.

            I can use my carrier with gevey , my problem is just one signal bar.
            I can call in and out , sms in and out and data with gevery. But MMS and facetime is gone.

            —————————————————

            For gevery, I followed the guide , and the successful rate for my sim/phone is about 60%.
            For those not successful, “No Sim installed” is not appeared after turned to airplane mode (I wait for quite a long time). and “You have just fail. so and so ” message appear after turn back o normal mode.

            Anyway , I guess it due to signal problem or carrier problem. And just a matter of try and fail.

          •  
            Wolverine5 years, 5 months ago

            Make sure you have not installed Ultrasn0w if you are using Gevey. I have not installed Ultrasn0w and i am seeing full signal bars after unlocking my iPhone 4 through Gevey. Can you tell me your signal-strength in dBs by dialing *3001#12345#* from your iPhone?

          •  
            sam5 years, 5 months ago

            Confirmed no Ultrasn0w.

            -113 db , no matter where and when

            can 3g data , can voice call , can sms

            no mms, no facetime

          •  
            Wolverine5 years, 4 months ago

            This confirms that problem is not with Gevey or your iPhone, its basically weak signal-strength in your area. You need to move into area where there is good signal coverage. -113 db is very very weak signal strength. I wonder how can you call or sms with such a weak signal-strength.

          •  
            sam5 years, 4 months ago

            Well…

            that’s wierd , the actually signal is really good indeed.
            am using 3 different cariers, 3 sim cards show the same -113 db everywhere, but can 3G data up to 2150kbps

            I guess I am stick with the one signal bar thing. anyway at least better than an ipod

            -__-“

          •  
            Wolverine5 years, 4 months ago

            Ok. Lets give it another try. Install Ultrasn0w 1.2.3 (NOT 1.2.2) and see if you get full signal-bars or not. A good signal strength is b/w -70 to -80 and signal strength above -110 means there is no possibility of communication. Now in your case, its opposite which means your iPhone is not showing the correct signal-bars as well as correct signal-strength in dBs. Ultrasn0w 1.2.3 is known to fix this issue on all those iPhone 4s who have old baseband (<04.10.01). Give it a try and do let me know.

          •  
            sam5 years, 4 months ago

            Horaaaay~!

            My signal bar is back and I got -50 db and sometimes -56 and -60.

            It works with gevey too.

            Thank you ~~

          •  
            Wolverine5 years, 4 months ago

            Glad that it worked for you :D

  •  
    cuxux5 years, 5 months ago

    Help,
    I installed ios 4.3.2 (clean restore) on iphone 4 using snowbreeze 2.6 + ultrasnow 1.2.2. Now i’m getting battery drain 20% on standby overnight (8 hours).
    Push off
    Mail off
    3G off
    wifi off
    Ping off
    Background apps off

    My phone will only last on standby for 40 hours on standby without using it at all.

  •  
    Jose Simoes5 years, 5 months ago

    Jaxov.. Is there a way to use this with Gevey? I read that Gevey does not work on custom firmwares..

    •  
      Wolverine5 years, 5 months ago

      Gevey SIM 100% works with custom firmwares UNLESS you install Ultrasn0w 1.2.2. Do NOT install Ultrasn0w if you are using Gevey SIM to unlock your iPhone.

      •  
        Mahesh5 years, 5 months ago

        Wolverine,
        I’ve heard some people say Gevey sim is illegal as it calls an emergency number. Is that true? Can I use it in US/ Canada?

        •  
          Wolverine5 years, 5 months ago

          You only have to call for emergency number 112 for 2 seconds. Yes, it is illegal and unethical.

      •  
        Jose Simoes5 years, 5 months ago

        The problem is that when I try to use a custom firmware on iTunes, I always get error 1601 when trying to do the Restore, Any ideas?

  •  
    dirkelozado5 years, 5 months ago

    hi. Need help. iphone 3G os 4.2.1 firmware 6.15 already jailbroken. unlocked with ultrasn0w 1.2.2. downgraded to 1.2.1 and fixed with djayb6 fixer. Still dont have signal. just one bar..or no bars at all. what should i do next?

    •  
      Wolverine5 years, 5 months ago

      Why you used DjayB fixer on iOS 4.2.1? Its only for iOS 4.3.x. Just uninstall it.

      •  
        dirkelozado5 years, 5 months ago

        Just to try someting else…with the ultrasnow 1.2.2 i have no signal or one bar no more..
        for the 3G the 4.2.1 is the latest os.

        my probles is i dont have signal…the jailbrake works fine

  •  
    Birchy5 years, 5 months ago

    Hey guys having sorta the same probes just wondering if sum1 could help me out I have firmware 4.3.2 bb 6.15.00 the iPad one I’m loosin my service and I’ve downloaded ultraslow 1.2.2 now I know there is a fixer for ultrasn0w but that’s where I’m stuck I try to install the djayb6 reppo and it won’t let me comes up with did not find repository this might be because u are trying to install a legacy repository I’m stumped I’ve search everywhere and havent fond ne one with the same problem so if sum1 knows wats up I’d really appeciate the help cheers

    •  
      Wolverine5 years, 5 months ago

      See the reply to Antonio here http://bit.ly/eHg7xI I told him the procedure to downgrade Ultrasn0w 1.2.2 to Ultrasn0w 1.2.1 and then use DjayB6’s fixer DEB.

  •  
    Mahesh5 years, 5 months ago

    Wolverine, I unlocked my phone last week using your guide. Then I had one signal bar issue on my 3GS that I downgraded the bb to 05.16
    After installing the ultrasnow fixer for 1.2.1, to noticed that my signal strength has increased from -118 dB to -89dB.
    1. Do you suggest I install untrasnow 1.2.2? What are the advantages?
    2. It still always only shows 4 out of 5 bars for me. My wife’s phone shows full bars with signal strength -73dB.

    Please advice

    •  
      Wolverine5 years, 5 months ago

      -89dB is fair but -73dB is very good signal strength. It depends on the baseband and the network you are using. Try to put your wife’s SIM card into your iPhone and see if you get full-signal bars? 2ndly definitely there are some signal-issues on iOS 4.3.x but they all are solved in Ultrasn0w 1.2.2. Install Ultrasn0w 1.2.2 and see if you get full-signal bars. If you are not satisfied, i will teach you how to downgrade back to Ultrasn0w 1.2.1 or Ultrasn0w 1.2.

  •  
    SlickRick5 years, 5 months ago

    Hi Wolverine!
    Is there a way of changing my baseband from 04:10:01 to something else so I can unlock my network?
    Or is there a way to downgrade from 4.3.2 to something else and reactivate my network?

    Please help! Thanks in advance!

    •  
      Wolverine5 years, 5 months ago

      Downgrading iPhone 4 baseband 04:10:01 is not possible at this moment. Also downgrading your firmware do not mean you are also downgrading your baseband.

      •  
        SlickRick5 years, 5 months ago

        Thanks for the insight.
        You made mention above of using “Gevey” to solve this problem.
        I’m based in Paris and wanted to know if this technology is only available in the US?
        Can you recommend any solutions?
        Thanks.

        •  
          Wolverine5 years, 5 months ago

          Its available worldwide. You need to read this first http://bit.ly/fQoQqc and then this http://bit.ly/f2n5VU

          •  
            SlickRick5 years, 5 months ago

            Thanks, I guess I have no choice but to get the sim. :(

            I’ll enquire on wether I can buy one locally or order one from applenberry.
            Thanks a lot for your help and keep up the good work!

          •  
            Wolverine5 years, 5 months ago

            Applenberry are the official Gevey SIM providers who actually made it.

      •  
        purehate5 years, 3 months ago

        hii Wolverine!
        my iPhone is restored and upgraded…
        now I cant see my baseband and IOS too
        when I slide to unlock my iPhone it shows only Dial screen
        when I connect to iTunes it shows…
        version NA
        Serial NA
        If I jailbreak with redsn0w …it hangs in waiting in reboot point..h
        so plz help mee

        •  
          Pramod5 years, 3 months ago

          For the stuck at the reboot & dial screen problems, make sure your running the latest RedsnowRC16. If not, download the updated version of the same from here http://bit.ly/kOhAeX. Once completed, check to see if you can read your Modem FW/iOS details from your iPhone Settings.

  •  
    Antonio5 years, 5 months ago

    Wolverine,

    I did all the downloads, placed all in autoinstall directory, rebooted, and I,m sorry to inform you that nothing changed…. the carrier continues to show ATT 10.0, but inside I have another SIM card (TIM).
    So, pacience is the word of order…. thanks to your effort in help me… regards. antonio.

  •  
    Antonio5 years, 5 months ago

    Hello, I did the jailbreak on my iphone 4 to ios 4.3.2 with sn0wbreeze 2.6 and it went fine. BUT the Unlock 4.3.2 iPhone 4 3GS Ultrasn0w 1.2.2 didn’t work for me. I followed all the steps, with the original SIM (ATT) and with my SIM (TIM), and the carrier remains ATT 10.0. Could anyone have some advice?
    Thanks.

    •  
      Wolverine5 years, 5 months ago

      Carrier only changes when you change the SIM in your iPhone. Also what is your current baseband? http://bit.ly/95CX7y

      •  
        Antonio5 years, 5 months ago

        Thanks for your help.
        My baseband is 1.59.00 and I do change the SIM, restart de device and, nothing! the SIM is TIM but it remains saying ATT. and is locked, of course.

        •  
          Wolverine5 years, 5 months ago

          So it do not pick T-Mobile SIM signals? Give Ultrasn0w fixer a try. First you need to downgrade to Ultrasn0w 1.2.1 http://bit.ly/hk4aDV (This this guide as a reference to downgrade Ultrasn0w 1.2.2 to Ultrasn0w 1.2.1) Once done, install DjayB6’s fixer tool http://bit.ly/i2d2ZC

          This is how it goes:
          1. Uninstall Ultrasn0w 1.2.2 from Cydia
          2. Install Ultrasn0w 1.2.1 DEB from that tutorial
          3. Install DjayB6’s fixer from Cydia

          •  
            Antonio5 years, 5 months ago

            I did uninstallled the ultrasn0w 1.2.2

            1. now, where I could find ultrasn0w 1.2.1?

            2. The http://djayb6.com, on cydia, returns that its invalid or could’t download

            so, I think I’m fucked….

          •  
            Wolverine5 years, 5 months ago

            Opsi. Just tested and found Djayb6’s repo is down. No worries, download Ultrans0w 1.2.1 DEB from here http://bit.ly/gnbmFd and fixer DEB from here http://bit.ly/gMpP6x

            1. Uninstall every previously installed Ultrasn0w installation.
            2. Place Ultrasn0w DEB in AutoInstall directory
            3. Reboot iPhone
            4. Place Fixer DEB in AutoInstall directory
            5. Reboot iPhone

            PS: I have informed DjayB6 about this repo!

  •  
    Brenden5 years, 5 months ago

    I jailbroke 4.3.2 with redsn0w, and it works great, but I got the 1 signal bar issue, installed ultrasn0w 1.2.2, and voila, my bars are back… BUT.. ever since.. I’ve been having issues with sending/receiving some text messages. Frankly, I’d rather have the annoying visual issue than usage issue.

    •  
      Wolverine5 years, 5 months ago

      Dial *3001#12345#* from your iPhone and tell me the signals in db.

  •  
    chewbacca5 years, 5 months ago

    Please build an unlock for baseband 05.15.xx and 05.14.xx I have two phone waiting for these updates

    •  
      Wolverine5 years, 5 months ago

      There will not no unlock for iPhone 3GS baseband 05.15.xx and 05.14.xx and it has been confirmed by MuscleNerd. Read more here http://bit.ly/hgfKdx

      •  
        chewbacca5 years, 5 months ago

        hmm. I will have no option then. How do I know for sure if upgrading the baseband will break my GPS or not? I cannot live without one I rather use an older phone. Thanks

        •  
          Wolverine5 years, 5 months ago

          There are 50% chances. Some people still got it working after upgrading to iPad bb but some lost it completely. I have heard that those who upgraded to iPad bb and still have their GPS working are getting inaccurate GPS coordinates etc. Final decision is yours!

          •  
            chewbacca5 years, 5 months ago

            I am willing to do it If I knew for sure that the baseband downgrader from 06.15.xx to 05.13 or less would be available soon.

          •  
            Wolverine5 years, 5 months ago

            I think only @MuscleNerd can answer to this question :)

          •  
            chewbacca5 years, 5 months ago

            I have a iPhone 3GS what is latest version jailbroken and unlocked on iPad baseband?

          •  
            Wolverine5 years, 5 months ago

            iOS 4.3.2 http://bit.ly/hmTtsH is still valid for all iPhone 3GS users with or without iPad baseband.

  •  
    irome5 years, 5 months ago

    which jailbreak process should i use ( snowbreeze or redsnow ) for baseband 04.10.01? thank you very much…

  •  
    Sreeni5 years, 5 months ago

    I’ve been waiting for the unlocks which can be used on unsupported basebands.. please help

    •  
      Wolverine5 years, 5 months ago

      Dev-Team is working on iPhone 4 NCK unlock method. Hopefully you will see some results in few months.

  •  
    Sreeni5 years, 5 months ago

    Hi,

    Could you please let me know when can the unsupported baseband iphone can be unlocked? or could you please let me know if there is a way to convert an iphone from unsupported baseband to a supported baseband. Thanks in advance.

    •  
      Wolverine5 years, 5 months ago

      You need to tell me your current baseband http://bit.ly/95CX7y

      •  
        Taoufik5 years, 5 months ago

        I have baseband 04.10.01
        can you tell us How long?

        •  
          Wolverine5 years, 5 months ago

          Only possible solution is Gevey. Do NOT expect iPhone 4 baseband 04.10.01 NCK unlock before next 3-4 months.

          •  
            SlickRick5 years, 5 months ago

            I’m experiencing the same problem, is it not possible to downgrade to either 4.3.1 or 4.2.1 and unlock the sim so I may be able to make phone calls?
            Thanks…

          •  
            Wolverine5 years, 5 months ago

            Downgrading firmware do not mean you are also downgrading your baseband. The only way to unlock your iPhone with baseband 04.10.01 is through Gevey. Its the latest baseband and do not expect its unlock anytime soon.

          •  
            Sreeni5 years, 5 months ago

            my baseband is also 04.10.01

            I’m currently in India, could you please let me know if I can use the Gevey solution here in India?

            Thanks

          •  
            Wolverine5 years, 5 months ago

            Yup, you can use Gevey SIM in India but do dial 112 from your current operator to make sure before making a final purchase!

  •  
    Ben5 years, 5 months ago

    Done :D I restored iOS 4.3.2 custom IPSW using iTunes and now my iPhone is jailbroken. I do not have Wifi rounter, is there any workaround to install Ultrasn0w 1.2.2 offline?